Changes

Jump to: navigation, search

Linux Mint: Serial port name bug on fitlet2 with Atom CPU

3,729 bytes added, 08:00, 12 September 2019
== Compile custom kernel ==
* Another way is to get serial port working is to recompile your kernel manually and disable unset CONFIG_SERIAL_DEV_BUS in menuconfig* The configuration path:Device Drivers > Character devices > Serial device bus
<pre>
> Device Drivers ->Character devices ───────────────────────────────────────────────────────────────── ┌─────────────────────────────────────── Character devices ───────────────────────────────────────┐ │ Arrow keys navigate the menu. <Enter> selects submenus --->(or empty submenus ----). │ │ Highlighted letters are hotkeys. Pressing <Y> includes, <N> excludes, <M> modularizes │ features. Press <Esc><Esc> to exit, <?> for Help, </> for Search. Legend: [*] built-in [ ] │ │ excluded <M> module < > module capable │ │ ┌───────────^(-)──────────────────────────────────────────────────────────────────────────────┐ │ │ │ <M> GSM MUX line discipline support (EXPERIMENTAL) │ │ │ │ < > Trace data sink for MIPI P1149.7 cJTAG standard │ │ │ │ [*] Automatically load TTY Line Disciplines │ │ │ │ [*] /dev/mem virtual device support │ │ │ │ [ ] /dev/kmem virtual device support │ │ │ │ Serial drivers ---> │ │ │ │ < > Serial device bus ---- │ │ │ │ </preM>TTY driver to output user messages via printk │ │ * As result in .config will appear: │ │ <M> Parallel printer support │ │ │ │ [ ] Support for console on line printer │ │ │ └───────────┴(+)──────────────────────────────────────────────────────────────────────────────┘ │ ├─────────────────────────────────────────────────────────────────────────────────────────────────┤ │ <Select> < Exit > < Help > < Save > <preLoad ># CONFIG_SERIAL_DEV_BUS is not set └─────────────────────────────────────────────────────────────────────────────────────────────────┘
</pre>
* We've build such kernels example .deb kernel packages for some distributionsDebian 10, missing device node will appear as /dev/ttyS2:
<pre>
# Debian$ wget https://path/to/linux-headers-4.19.67-compulab.2019.09.11_4.19.67-compulab.2019.09.11-1_amd64.deb$ wget https://path/to/linux-image-4.19.67-compulab.2019.09.11_4.19.67-compulab.2019.09.11-1_amd64.deb
$ sudo dpkg -i linux-headers-* linux-image-*
$ sudo reboot
...
$ cat /boot/config-4.19.67-compulab.2019.09.11 | grep CONFIG_SERIAL_DEV_BUS
# CONFIG_SERIAL_DEV_BUS is not set
 
## Test with serial loopback cable:
$ sudo -i
$ echo "12345678" > /dev/ttyS2
$ cat /proc/tty/driver/serial
serinfo:1.0 driver revision:
0: uart:16550A mmio:0x7FFFF10000 irq:4 tx:0 rx:0
1: uart:16550A mmio:0x7FFFF0E000 irq:5 tx:0 rx:0 CTS
2: uart:16550A mmio:0x180000000 irq:6 tx:10 rx:10
3: uart:16550A mmio:0x7FFFF0C000 irq:7 tx:0 rx:0 CTS
</pre>
 
[[category:fitlet2]]
[[category:linux]]
[[category:software]]
422
edits