View unanswered posts | View active topics It is currently Tue Jan 28, 2020 7:51 pm

Reply to topic  [ 3 posts ] 
 Unable to Access BIOS with F2 
Author Message

Joined: Thu Feb 19, 2015 1:21 am
Posts: 2
Post Unable to Access BIOS with F2
I have recently purchased an IPC2 and am trying to access the BIOS. Whether I hold the F2 key down on boot or try to click it fast when the Setup message pops up, I am unable to access the BIOS before the Operating System appears (Windows 8.1) I have BIOS version IPC2_3.330.3 X64 which I believe is the latest version. All the BIOS settings should be at the defaults and I have tried the steps on the troubleshooting page including pressing the reset button inside the case.

My eventual goal is to reinstall the OS via USB or DVD drive but the computer does not appear to boot to these devices first. Any more steps that I should try?


Thu Feb 19, 2015 1:32 am

Joined: Sat Feb 21, 2015 11:26 am
Posts: 1
Post Re: Unable to Access BIOS with F2
Hi smtpc,
I have probably the same problem, since I tried to enter on the bios configs by keeping pressed F2 button: actually, it works but is not a "normal" bios...just few settings and that doesn't take any effect once you press the enter button on your choice. You can press the F8 button, it works as well as F2 button.
The point for me should be to be able to disable the Auto-On mode: I would like to disable it, but how is it possible if I cannot access to a bios config setup?

I'll stay tuned if anyone want to help me.

Sat Feb 21, 2015 11:33 am

Joined: Thu Feb 19, 2015 1:21 am
Posts: 2
Post Re: Unable to Access BIOS with F2

After surfing around, I came to the conclusion that my BIOS was booting into UEFI rather than legacy mode. With UEFI, it appears that it is near impossible to time the F2 keypress accurately enough to get into the BIOS.

To solve my issue, I installed Windows 8.1 on a spare drive and following directions similar to the ones on the url below, I disabled UEFI BIOS and made sure the legacy BIOS was enabled: ... cure-boot/

After that I was able to reinstall my OS and get everything working again.

Good Luck.

Sun Feb 22, 2015 3:07 am
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.