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1 Introduction 

1.1 Introduction 

 
Phoenix BIOS Editor Pro is a Windows application that provides an easy-to-use 
interface for modifying the BIOS without having to re-build the BIOS. BIOS Editor 
allows you to modify the pre-built ROM image without the source code.  
 
BIOS Editor automatically decompresses a single ROM image back to the small ROM 
modules that are part of a BIOS project. 
 
When you modify a ROM image, BIOS Editor incorporates your changes into a new 
BIOS image that can be written to a flash part.  

2 Getting Started 

2.1 Prerequisites 

Be sure that your system meets the following Software requirements: 
• Windows 95/NT/2000/XP/Vista 
• The BIOS.ROM or Build products for a Phoenix BIOS 

2.2 Installing BIOS Editor 

Perform the following steps to install Phoenix BIOS Editor: 

1. From Windows, run BIOSEdit.exe to install BIOS Editor in the directory of 
your choice. 

2. Follow the onscreen instructions. 

2.3 Uninstalling BIOS Editor 

Perform the following steps to uninstall Phoenix BIOS Editor 
1. From the Windows Start menu, select Settings. 
2. Select Control Panel. 
3. Select Add/Remove Programs. 
4. Select Phoenix BIOS Editor. 
5. Click Remove. 
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2.4 Using Online Help 

1. Press <F1> while the screen is displayed. The corresponding topic displays in 
a Help window. 

2. Click the blue links to view additional information. Click Back to return to the 
previous Help topic. 

 

 

3 Opening, Editing and Saving a BIOS Image 

3.1 Starting BIOS Editor 

Perform any one of the following steps to run BIOS Editor in Windows: 
• Double-click on the BIOS Editor icon in the BIOS Editor group. 
• Double-click on BIOSEDIT.EXE in the Explorer. 
• Run BIOS Editor from the Run box on the Start menu 

The program opens with an empty window. 

3.2 Editing a BIOS Image 

Perform the following steps to edit a BIOS image. 
1. Open the File menu and select Open.  
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2. In the dialog box, select the ROM image you want to edit and select the 
OPEN button. The program opens a window with a number of Editor 
Windows. 

3. Select the window that you want to edit and modify the value fields.  
 

Refer to the following sections for descriptions of changing the field values in 
the different windows. The windows available for a ROM File are: 
• BCP Editor  
• Register Editor  
• DMI Strings  
• The Setup Table Editor  
• The String Editor  
• The PCI Routing Table 
• The Quiet Boot Logo Editor  
• Default Boot Sequence Table 

 
4. To finish editing the BIOS image, select Build BIOS on the File menu to save 

the new ROM image. 

3.3 Building BIOS 

When you finish editing the BIOS image, select Build BIOS on the File menu or click 
the Build button (shown below) to save the new ROM image.  

 
 

A report will be generated after you build the BIOS. If the building is successful, BIOS 
Editor will ask you to save the new BIOS. 
 
Note: The Build button is available only when BIOS image is changed.  

4 BIOS Editor Window 

The BIOS Editor Window consists of these basic elements: 
• The Title Bar at the top 
• The Menu Bar  
• The Toolbar  
• The Project Panel on the left showing the project elements 
• A set of Editor Windows for editing the project elements 
• The Status Bar at the bottom 
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4.1 Menu Bar 

4.1.1 The File Menu 

The following describes the commands available on the File menu: 
 
Open <Ctrl+O>   Open a project for editing  
Close      Close the editing project 
Build BIOS <Ctrl+U> Create a new ROM image from a Project, incorporating 

changes 
Exit      Exit BIOS Editor 

4.1.2 The View Menu 
The following describes the commands available on the View menu: 
 
Tool Bar          Display or hide the Tool Bar 
Status Bar       Display or hide the Status Bar 
Project Panel       Display or hide the Project Panel 

4.1.3 The Edit Menu  

The following describes the commands available on the Edit menu. This menu is 
available only when the ACPI Editor is active. 
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Cut <Ctrl+X>    Cut selected code to the Windows clipboard. 
Copy <Ctrl+C>   Copy selected code to the Windows clipboard. 
Paste <Ctrl+V>   Paste code from the Windows clipboard to ACPI Editor. 
Del <Del>    Delete selected code. 
Find <Ctrl+F>   Display a dialog to find specifically code. 
Find Next <F3>   Find code specified in Find dialog. 
Select All    Select all content in ACPI Editor. 

4.1.4 The Windows Menu 
The following describes the commands available on the Windows menu: 
 
Use the commands on the upper half to arrange the Editor windows and their icons. 
Use the commands on the lower half to open the available Editor windows. A grayed 
command indicates that the window not available.  
 
Cascade <Shift+F5>    Display the Editor Windows one behind the other. 
Tile Horizontally <Shift+F4>  Tile the Editor Windows horizontally. 
Tile Vertically <Shift+F3>   Tile the Editor Windows vertically. 
Arrange Icons  Arrange the minimized icons of the Editor 

Windows. 
BCP Editor <Ctrl+B>    Open the BCP Editor.  
Register Editor<Ctrl+R>   Open the Register Editor. 
String Editor <Ctrl+S>   Open the String Editor. 
Setup Table Editor <Ctrl+T>  Open the Setup Table Editor. 
PCI IRQ Table Editor <Ctrl+I>  Open the PCI IRQ Table Editor. 
DMI Editor <Ctrl+D>    Open the DMI Editor. 
Quiet Boot Logo Tool/Splash  <Ctrl+Q> Open the Quiet Boot Logo/Splash Screen 

Tool 
ACPI Editor <Ctrl+A>    Open the ACPI Editor 
Default Boot Sequence Table <Ctrl+N>  Open the Default Boot Sequence Table 
 

4.1.5 The Help Menu 
The following describes the commands available on the Help menu: 
 
Contents<F1> Display Online Help of BIOS Editor 
About   About Phoenix BIOS Editor 

4.2 Toolbar 

The following icons display on the toolbar. 
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These icons are summarized below: 
 

 Open file (Ctrl+O) 

 Build BIOS (Ctrl+U) 

 Display BIOS Configuration Parameters window (Ctrl+B) 

 Display Register table window (Ctrl+R) 

 Display DMI Strings window (Ctrl+D) 

 Display String Editor (Ctrl+S) 

 Display Setup Table (Ctrl+T) 

 Display PCI Routing Table (Ctrl+I) 

 Display Quite BootLogo (Ctrl+Q) 

 Display ACPI Editor (Ctrl+A) 

 Default Boot Sequence Table (Ctrl+N) 

 

4.3 Project Panel 

The Main Window displays a Project Panel with a tree of the items in the Project. 
This window marks the modules and other items that are included in your project 
with a plus sign (+). Click on the plus sign or double-click the name of the item to 
expand and display it. 
 
When you choose ACPI.AML/ACPI.BIN, ROMEXEC#.BIN, TEMPLATE#.BIN, 
STRING#.BIN, the related Editor Window will activate on the right. When selecting 
other nodes, the enabled buttons at the bottom of the window indicate whether you 
can Add, Remove or Change an item. 
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4.3.1 Add/Change a Module 

If the Add or Change button is enabled when you expand an item on the Project 
Window, selecting it brings up a dialog box for importing a new module into the 
project. 
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Perform the following steps to add a new OEM module. 

1. Enter the File Name of the new module. 
2. Check and enter the Output File Name. 
3. Check and enter the Footprint Size. 
4. Check to Disable Compression. 
5. Select Import to open the Browse window for naming the import file. 
6. Select OK. 

 
Note: FFS BIOS does not support an Output File Name. 

4.3.2 Edit the ROM Flash Banks 

Perform the following steps to edit the ROM Flash Banks. 
1. Select Banks Setting on the Project Panel.  
2. Select the Change button. This opens a dialog box.  
3. From either drop-down box, select a new value and click OK. 

 
Note: FFS BIOS does not support an Output File Name. 

 

4.3.3 Edit the Memory Hole 

Perform the following steps to edit the Reserved Memory Hole. 
1. Select Hole Settings on the Project Panel.  
2. Select the Change or Add button. This opens a dialog box as shown below.  
3. When changing a HOLE, BIOS Editor will ask you that whether the HOLE is 

compressed. If it is compressed, select YES, otherwise, select NO. 
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4. In the Hole Size data-entry field, enter the size of the Memory Hole hex value 

in bytes.  
5. In the Locate data-entry field, enter the location address hex value in bytes.  
6. Select Import User Data and specifying a data file fills the hole with this data.  
 

Note: Legacy BIOS does not support compressed HOLE. 

4.3.4 Edit the Quiet Boot Logo 

Perform the following steps to edit the Quiet Boot Logo. 
1. In the Project panel, expand the Quiet Boot Logo folder. (Note that this 

option is only available if a Quiet Boot Logo file was specified in the build.) 
2. Click the logo file. 
3. Click the Change button. 

 
The Quiet Boot Logo window has the following commands available on the 
command line: 
 

Copy Copy the displayed picture to the clipboard. 
Paste Paste the contents of the clipboard.* 
Import Load a Windows .bmp or .jpg file.* 
Export Save displayed picture. 
Load Load a compiled .bin logo file. 
Save    Save displayed picture as a .bin logo file. Note that you are 

required to include a modified or new logo in LOGODATA.BIN.  
*The Paste and Import commands require that the width of the bitmap be in multiples of 8. 

 
On the left side of the window, the following options are available when the items 
are enabled: 
 

Logo Enable Check to enable Quiet Boot Logo. 
Fade In Check to enable logo Fade In.       
Fade Out  Enable or disable logo Fade Out. 
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Setup Prompt Enable Setup Prompt during POST. If enabled, specify the 
X,Y coordinates (80x25) for the prompt. Select the 
background color from color grid using the right mouse 
button. Finally, select the text color using left mouse 
button. 

Logo Location  Check Center if you want the logo centered. Otherwise, 
enter the X,Y coordinates (80x25) for the top left corner. 

4.4 The Editor Windows 

Note: The Editor Windows are platform specific. Some windows may be missing 
from a particular platform or build. In each window, the items displayed can also 
vary considerably depending on the devices installed on the platform and the 
features installed for the build. 

4.4.1 The Setup Table Editor 

You can use the Setup Table Editor to edit the Phoenix Setup Utility. 

 
Selecting the Setup Table Editor displays a window divided into two panels. The left 
panel displays groups of Setup Nodes, as organized in the file TEMPLATE.ASM. The 
right panel shows the current settings for each mode. Each line in the panel displays 
the editable elements of the Node. These include the following: 

Type (read-only) 
System Default (S_Default) 
Manufacturer's Default (M_Default) 
Description 



 

Phoenix BIOS Editor User Manual  11 

Help Text 
 

Note that you can edit all settings except the Type.  
 
to change a System and Manufacturing Default setting, select the value that you 
want to change by double clicking it or selecting it and pressing <Enter>. An asterisk 
(*) indicates the field is turned on. 
 

 

 
To change the Description and Help, select the value that you want to change by 
double clicking it or selecting it and pressing <Enter>. The “Please enter new string” 
dialog box displays. 
 

 

 
Enter the new description or help and press OK. 
 
Perform the following steps to edit the settings: 

1. In the left panel, click the nodes beside the group you want to edit. The right 
panel changes. You can scroll down to view additional lines. 

2. In the right panel, double-click the text you want to change.  
3. Edit the string that displays. Enclose text strings in single quotes such as: 

'changed text' 
4. Click OK. 
5. Click the Emulate bar to view an emulation of the edited setup screen. 

 
To view an emulation of a screen, click the Emulate bar: 
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On the emulated screen, you can perform the following tasks. 

1. Select blue text on the emulated screen to display item-specific Help in the 
right area of the screen. 

2. Double-click a bulleted item to change to another emulated screen. 

 
Use the right or left arrow to browse through emulated screen. 
 
Note: The Setup Table Editor window in the user interface is linked to the String 
Editor window. Changes in one window affect the other window. 

4.4.2 The String Editor 

 
The String Editor allows you to modify both setup strings and POST messages. 

 

 
Perform the following steps to modify a string. 

1. Double-click an item to open a data entry box. 
2. Edit the string.  
3. Click OK to close the box and save your edit.  

 
To modify the Evaluation Sign-on or OEM Sign-on string, click Eval Signon or OEM 
Signon, and edit the string. 
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Perform the following steps to locate a string. 
1. Click the Find button. 
2. Type the string you want to find and click OK. 
3. Click the Find Next button to locate the next occurrence of the string. 
4. Repeat step 3 until you find each occurrence. 
 
Notes: 

• The String Editor window in the user interface is linked to Setup Table 
window; changes in one window affect the other window. 

• The String Editor cannot edit DBCS strings. 

4.4.3 The BCP Editor 

The BIOS Configuration Parameters (BCP) window allows you to view the values of 
the BCP structures and changing them. Settings can be loaded and saved. 
 

 

Selecting the BCP Editor displays a window for editing the BIOS Configuration 
Parameters (BCP), which are data values stored in the BIOS code that control the 
behavior of BIOS routines during POST, Setup, and Run Time. The BIOS build uses 
special macros to create and format these parameters in a set of special BCP 
structures. For example, BIOS read-and-write routines that access the chipset use 
data stored in the chipset BCP structure to determine the index and data-port 
addresses for the chipset and the width of the registers.  
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Use the Save button at the top to create and name a new .bcp file, which you can 
use in other projects. The Save button stores the current selections. Use the Load 
button to load a .bcp file with the selections specified in another project.  
When you select a BCP structure in the top panel by clicking a radio button, the BCP 
Editor displays the related BCPs, the current value, and a short comment describing 
the function of the BCPs. You can change the Values in this window but not the 
Descriptions or Comments. 
 
Notes:  

• An asterisk (*) indicates the field is turned on. 
• There are two methods of changing BCP values: 

o Turn an item on (*) or off by double-clicking the value or by pressing 
<Enter>. See Selection Fields. 

o Change the value by double-clicking the value and modifying it. See 
Value Fields.  

4.4.4 The Register Editor 

The Register Tables window allows you to change the initialization values that are 
used for setting up chipsets. These values can be loaded from and saved to *.REG 
files. 
 

 

Perform the following steps to edit the registry. 
1. Select a register-configurable device in the top panel by clicking a radio 

button. The editor displays the related register values in the bottom panel.  
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2. Double-click an item in the Mask or Values column. Note that you cannot 
edit the Types, the Index, or the Comments. The register values are of two 
types: 
• Initial POST Values: This is loaded early in POST. 
• Setup Defaults: These are the register values loaded in Setup or late in 

POST if the CMOS checksum is bad or if AutoConfiguration is installed.  
3. Edit the value. 
4. Click OK. 
5. To save the edited registry as a new file, click the Save button and name the 

file. 

4.4.5 The DMI Editor 

The DMI Editor window allows you to change the values of the DMI strings.  

 

If you are editing a ROM image, selecting the DMI Editor displays a window similar to 
below: 
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Note that you can only change the String values in this window. 
 
4.4.5.1 BIOS Project DMI Editor 
If you want to edit DMI information, select the DMI Editor.  
Use the Save button on the top of the window for saving .dmi tables with the 
currently specified values. Later, you can use the Load button to insert these DMI 
values in other projects. 
  
Clicking the combo box in the top panel displays a different DMI structure and the 
currently specified values in the bottom panel. Double click on a selection field to 
change it. Double click on a value field to change the value and enter the new value 
in the data-entry box. 
 
Note: You cannot add new DMI structures to the BIOS image if they are not already 
there. For example, if you attempt to add new slots or connectors not in the original 
BIOS, the Build will fail.  

4.4.6 The PCI Routing Table 

The PCI Routing window allows you to change the routing for PCI devices, change 
device numbers, change slot labels, and set bits in the PCI IRQ mask. Note that an 
exception is an embedded device, which only supports setting device numbers and 
the IRQ mask. 
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PCI interrupts are routed through the chipset to the Peripheral Interrupt Controller 
(PIC) and are level triggered. Most PCI chipsets provide for PCI-IRQ routing, a 
programmable mechanism using chipset registers for routing interrupts from PCI 
devices (embedded devices or slots) to IRQ lines (0 to 15) on the PIC. 
Most PCI devices do not care which IRQ they use, and the PnP software assigns them 
automatically. Exceptions such as PCI IDE devices, however, require the use of a 
particular IRQ. 
 
PCI devices can have up to four physical interrupt lines, INTA to INTD. Single function 
devices always use INTA. On multi-function devices, these four lines can be assigned 
to different functions of the device. More than one function can be assigned to the 
same interrupt line. 
 
Furthermore, since the PCI devices can share the same interrupt lines, different 
functions from different devices can share the same interrupt line, as shown in the 
following illustration. Different interrupt lines can share IRQs on the Programmable 
Interrupt Controller (PIC).  
 
When more than one slot is tied to the same PIRQ, a cascading query of the device 
drivers determines which function on which PCI device initiated the interrupt.  
PCI interrupt routing. This illustration shows the hardware connections in a typical 
PCI platform. Different chipsets/platforms support different configurations and a 
different number of slots. 
 

 
 
PCI interrupt routing. This illustration shows the hardware connections in a typical 
PCI platform. Different chipsets/platforms support different configurations and a 
different number of slots. 
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The Conflict Detection and Resolution (CDR) algorithm in POST uses two PCI Routing 
tables to determine which IRQ to assign to which PCI device: 
 

• The Device-Bridge Hardware Connections: On the device-bridge (right) side, 
there is a table in the BIOS that describes which PIRQ is hardware-connected 
to which INT# line on each device. For example, INTA of Device 2 is 
connected to PIRQ2 on the bridge, INTB to PIRQ3, INTC to PIRQ0, and INTD to 
PIRQ1. 

 
• The Possible ISAInterrupt-PIRQ Connections: On the ISA-bridge (left) side, 

there another table for each device with IRQ bitmaps that describe which ISA 
interrupts can be selected and connected to each PIRQ. Each bit set 
represents the IRQ available for that PIRQ for a specified device. 

 
Take the following into consideration when modifying fields on the PCI Routing 
window. 
 
Bus Number: The host bus number of the slot or embedded device. Identify a device 
as embedded with the "0" bus number. 
 
Device Number: The device number assigned to the slot by the IDSEL connected. 
This is a number from 0 to 20. 
 
Slot Number: The slot number silk screened on the board for the slot. This should be 
zero for embedded devices and nonzero otherwise. If there is no number visible on 
the board, the numbers should be 1 based, incremented for each slot. 
 
INTA, INT B, INT C , INT D: These entries describe the INT-PIRQ connections for each 
device as determined by the hardware connections. Valid entries are 0 to 3, not 
necessarily in that order. These entries represent which PIRQ (PIRQ0-PIRQ3) is tied 
to which interrupt line (INTA-INTD) on the slot. The PIRQ is a zero based number, 
often 0-3 or in some chipsets 0-15. An empty field indicates that the INT line is not 
tied to a PIRQ. 
 
IRQ Bitmap A, IRQ Bitmap B, IRQ Bitmap C, IRQ Bitmap D: These bitmaps describe 
the IRQ lines that can be mapped for the four INT lines (INTA-INTB) for each device, 
where each bit set represents the IRQ available for that PIRQ. For instance, indicate 
IRQ 10 by setting the 10th bit. These assignments can be different for each slot. 
 
Select the INTA...INTD columns of the PCI Routing Table window to specify which 
PIRQ is tied to which slot interrupt line. For instance, under INTA for a certain device, 
enter 01 if INTA is connected to PIRQ1, 02 for PIRQ2, etc.  
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Select the IRQ column to the right of the related INTA...INTD columns to change the 
bitmaps specifying which IRQs are available for a specific device interrupt line. 
Selecting the IRQ field brings up a dialog box similar to the following: 
 

 

  
Click the numbers of the IRQs available for this particular device interrupt line, and 
then select OK when you are finished.  
 

4.4.7 The Splash Screen 
The Splash screen editor allows importing a new image, exporting the current image, 
edit the script file of Splash screen and emulate the logo screen. 
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Tab descriptions 

 
 
Palette (read-only): This tab shows the global palette that will be used for all 
images. It is for reference only and is not editable. This palette of up to 256 colors 
varies and is derived from the colors that comprise each splash screen image. This 
palette is optimized on each build by the utility BOOTSCRN.EXE. During the palette 
optimization process, colors on some images may be adjusted slightly, as all image 
colors must conform to the global palette that has a maximum of 256 colors.  
 
Script: This tab displays the unassembled script file. The script informs the splash 
screen engine how the splash screen was constructed. Note: Editing script requires 
technical knowledgeable; otherwise the splash screen might be corrupted. Changing 
script is deprecated. 
 
Rounded Arc (read-only): This image is one of two images in the lower-right corner 
of the splash screen. This graphic is not editable. No other graphic can replace it. 
 
Small Logo (read-only): This image is one of two images in the lower-right corner of 
the splash screen. This graphic is not editable. No other graphic can replace it. 
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Prompt Logo: This image shows the setup prompt that appears in the lower-left 
corner of the splash screen. You can customize it by importing a new graphic that 
you create by clicking the Import button. Refer to the limitations described in the 
FirstBIOS Splash Screen Customization Guide. 
 
Response Logo: This image shows the message that displays immediately after the 
user presses the setup key or Firstar launch key. You can customize the text by 
importing a new graphic that you create by clicking the Import button. You can also 
copy the image and modify it; click the Copy button. Refer to the *limitations 
described in the FirstBIOS Splash Screen Customization Guide. 
 
Tile Logo: This image shows the graphic that fills the background of the splash 
screen. You can import a new image. You can also export the current image, modify 
it and then import it. 
 
Main Logo #n: This image shows the main logo(s) to be displayed on the splash 
screen. nnn is the index number of the logo and must match the index number 
specified in the script. You can import a new image. 
 
Transparent color: You can create transparent areas in the main logo by designating 
one transparent color. The current transparent color is indicated above the image. 
To assign a different color to be the transparent color, click that color within the 
image. If you do not want to have any transparent color, right-click anywhere in the 
image. 
 
Button descriptions 

 
 
These are enabled only on tabs with editable content 
 
Copy: Copies the currently displayed image to the Windows clipboard. You can then 
modify it using in the graphics application of your choice and paste or import the 
new image. 
 
Paste: Pastes an image from the Windows clipboard to this tab, replacing the current 
image. 
 
Import: Importing an image so you can replace the current image with a selected 
image file. 
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Export: Displays a Windows dialog so you can save the current image and modify it 
using the graphics application of your choice. Once you modify it, you can import the 
new image. 
 
Emulate: Generate a demo picture so you can view an emulation of a screen. Note: 
New image is not always available depends on of the size and complexity. 

4.4.8 The ACPI Editor 
The ACPI Editor disassembles AML (ACPI Machine Language) code back to ASL (ACPI 
Source Language) code. This allows the user to modify any portion of the ASL code, 
re-compile the modified ASL to AML, and then put it back to BIOS ROM. 

 
If the user has provided a compliant ASL compiler, then the AML code can be edited. 
(Note: Currently only Microsoft’s ASL.EXE works.) If the ASL compiler is not available, 
it will read only. 




